Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
amiga 500 mini
#1
hi,

ich wusste nicht wohin damit, dann tu ichs mal hier hin.

also, ich programmier grad nen kleines ballerspielchen,
amiga classic aga , in den grafikoptionen kann man parallax scroller,
später particle dichte etc aus und zu schalten

die grundversion rennt sogar auf ner 7 mhz emulation, zwar extrem schleppend aber geht
nackter a1200 emu rennt es gut (die 7 und 14 mhz emus sind wirklich genau)
und auf 28 mhz mc68030 emu ist das eigentliche zielsystem

das problem ist, sobald ich es auf meinen amiga mini werfe
gibt es soundprobleme, ich benutze die normalen tracker befehle

ich hatte das gleiche mit nem vertikal shooter, da benutze ich das
thx-soundsystem, da blieb der sound für 1-2 sekunden immer stehen
...darum hab ich dieses geile projekt eingestampft

im amiga mini menu kann man cpu jit und copper und eben fast blitter
einstellen, nur als schalter

schnellen copper kann man bei allen blitz games vergessen, da wird der
bildschirm alle paar sekunden verschoben

blitter unterstützung läuft dann wirklich schneller, wenn man mal einen
wirklich voll-geblitteten bildschirm hat

aber egal was man einstellt, die soundprobleme bleiben

es wäre extrem schade, da ich das game ja eigentlich für den amiga mini
raushauen wollte, da mit der kiste wieder nen einheitliches system da ist

auf linux benutze ich den amiberry emulator, der gleiche ist auf dem mini
selbst wenn ich die gleiche konfig nehme geht es nicht

hat jemand auch so ein problem, wie kann man es lösen

--------------
edit
im anhang ist ne kleine demo

im startscreen [F1] zum spielstart
joystick steuerung...ballern halt Wink
[ESC] beendet das game...oder testlevel beendet sich selber am ende
im spiel [F1]-[F3] waffenwechsel


Angehängte Dateien
.zip   dashoota.adf.zip (Größe: 134,94 KB / Downloads: 98)
Zitieren
#2
Unter WinUAE sind die Sound-Optionen eine eigene Geschichte für sich, da hatte ich öfters mal Probleme, insbesondere auf langsamen älteren Laptops.

Wie das unter Amiberry ist, weiß ich nicht.
Amiga. Just to let ya know....
Zitieren
#3
Eben unter FSUAE getestet, also im Menu ist der Sound einwandfrei, A1200 strict.

Btw, sieht cool aus, muß mal den Gamecontroller auspacken... Big Grin 

   
Amiga. Just to let ya know....
Zitieren
#4
also das "z" ist nur weil ich "blit asc("Z"),x,y"  getestet hab, ob er die font eingeladen hat Smile

hab es eben hinbekommen, den mini zum absturz zu bringen, man kann also nicht die 
config 1:1 übernehmen

aber da ich aminimiga laufen hab mit 90 mhz auf der kiste, geh ich davon aus , dass
es nur eine frage der zeit und der tests ist... Smile

wegen dem sound, ich denke mal das die tracker befehle im interrupt auf 50mhz 
laufen, aber irgendwie scheint der emu irgendwie/wo zu hängen

natürlich ist das demo mit gegnern zu überladen, aber die musi sollte ja doch unabhängig
der blit-rate laufen
im emu auf linux rennt es flüssig bei cpu-speed 25 mhz
Zitieren
#5
Wenn ich Zeit habe am WE, werde ich mal Pimiga oder so am Pi ausprobieren, und schauen, was mit dem Sound ist.
Amiga. Just to let ya know....
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste